Alter.Org.UA  
 << Back Home RU ru   Donate Donate www/www1/www2

Building NT kernel mode drivers in MS Visual Studio 8.0 (VS 2005)
for x64 (AMD64) platform

Hi, people! Now I'm publishing instruction for creating 64-bit (x64) NT kernel-mode driver project in MS Visual Studio 8.0

Contents

Set environment variables

Set BASEDIRNT4, BASEDIR2K, BASEDIRXP, BASEDIR2K3 environment variables (I would recommend system ones, not user-specific) like this:

BASEDIRNT4 = C:\Develop\DDKNT4
BASEDIR2K  = C:\Develop\DDK2000
BASEDIRXP  = C:\Develop\DDKXP
BASEDIR2K3 = C:\Develop\DDK2003

Set BASEDIR environment variable to point to your favorite DDK (I prefer NT4, because I'm writing highly compatible drivers). But latest time DDK 2003 is oftenly used. So we shall tune template project for DDK 2003. See migrating VC6 driver project to VC8 with DDK 2003 for DDK 2003 specific details.
Attention! If you want to build driver under VC8, make sure that x64 platform support is installed there. Also note, that DKK 2003 is mandatory.

BASEDIR = %BASEDIR2K3%

Create project

  • File -> New... -> Project
  • Chose Visual C++ -> Win32 in Project Types tree.
  • Chose Win32 Project in Templates list.
  • Enter project name, directory path and solution name. As usually. You can also uncheck Create directory for solution box. Then both project file (.VCPROJ) and .SLN will be created in same directory. By default Visual Studio 8 creates separate subdirectory for project.
  • OK -> DLL, Empty project -> Finish

Adding files

  • Just add files to your project. Project -> Add Existing Item or Project -> Add Item
  • If you decided to use .PCH, do not forget to insert the following line in all added *.C and *.CPP files
    #include "stdafx.h"
    
    instead of
    #include <ntddk.h>
    .....
    

Change project settings

  • In order to have access to all necessary options make sure that your project has at least 1 .C/.CPP file. A would recommend to use .PCH and initially add the following files
    driver_template.cpp
    drv_common.h
    StdAfx.cpp
    StdAfx.h
    
    All these нou can find in samples: driver_template_v7.rar/tgz (9.4 Kb/10.1 Kb)
  • Project -> Properties
  • Clisk on "Configuration" button (top-right corner)
  • Chose "All Configurations" in "Settings for" combo (top-left corner)
    • Chose <New...> in Active Solution Platform combo.
    • "Type or select new platform" = x64
    • "Copy settings from" = Win32
    • OK
    • If you need not Win32 platform at all, chose <Edit...> in Active Solution Platform combo and remove it.
    • And now chose x64 in Active Solution Platform combo.
    • Close
  • Configuration Properties -> General
    • It worth replacing $(SolutionDir) for $(ProjectDir) in "Output Directory" and append "-and64" at the end. You will get $(ProjectDir)\$(ConfigurationName)-amd64.
    • "Character Set" = Not Set
    • "Whole Program Optimization" = No Whole Program Optimization
  • Configuration Properties -> C/C++
    • -> General
      • Enter paths to DDK INCLUDE directories into "Additional include directories" edit:
        $(BASEDIR2K3)\inc\ddk\wnet,$(BASEDIR2K3)\inc\ifs\wnet,$(BASEDIR2K3)\inc\wnet,
            $(BASEDIR2K3)\inc\crt
        
        Note 1: here the separator character is comma. Do not take paths in quotation marks.
        Note 2: here I use wnet in contrast to wxp from previous manuals.
      • "Debug Information Format" = "Program Database (/Zi)".
      • "Detect 64-bit Portability Issues" - as you like. Affects additional compile-time checks for operations with pointers.
    • -> Optimization
      • "Whole Program Optimization" = No
    • -> Preprocessor
      • Enter the following predefined constants into "Preprocessor definitions" edit This will make all .H being compiled properly:
        WIN64, _WIN64, _AMD64_=1, _M_AMD64
        _WINDOWS, STD_CALL, CONDITION_HANDLING=1,
        NT_INST=0, _NT1X_=100, WINNT=1,
        WIN32_LEAN_AND_MEAN=1, DEVL=1, FPO=1
        
        Add the following defines to "x64 Debug" configuration:
        DBG, DEBUG, _DEBUG
        
        Note 1: here the separator character is comma. Do not take items in quotation marks.
        Note 2: You can place these defines to your .H used for building .PCH or some common .H file. Look for example with *.cpp files in pch_cpp_x64 folder and with *.c files in pch_c inside driver_template_v7.rar/tgz (9.4 Kb/10.1 Kb) archive. Note 3: And if you want to keep both Win32 and x64, put common defined to header and platform-specific - to project settings.
    • -> Code Generation
      • "Enable String Pooling" = "Yes (/GF)"
      • "Enable C++ Exceptions" = "Yes (/EHsc)"
      • "Basic Runtime Checks" = "Default"
      • "Struct member alignment" = "8 Bytes (/Zp8)"
      • "Buffer Security Check" = "No (/GS-)"
    • -> Language
      • "Enable Run-Time Type Info" = "No (/GR-)"
    • -> Precompiled Headers
      • "Create/Use Precompiled Header" = "Create Precompiled Header (/Yc)"
      • "Create/Use PCH Through File" = "StdAfx.h"
    • -> Advanced
      • "Calling convention" = "__stdcall (/Gz)"
    • -> Command Line Remove "/GZ" from "Win32 Debug" configuration. In most cases this will save us from such trouble as "Debug build works, but Release doesn't". Builds will not differ in bug reproducing (uninitialized variables and memory blocks, overflows, etc.). In addition, this pretty switch instructs compiler to include stack consistency check code into output. This check leads to unresolved external _chkesp on link stage.
  • Configuration Properties -> Linker
    • "General"
      • Enter driver binary'es name (e.g. "driver_template.sys") in "Output File" edit.
      • "Enable Incremental Linking" = "No (/INCREMENTAL:NO)"
      • "Ignore Import Library" = "Yes"
      • Enter paths to DDK libraries in "Additional Library Directories". For example
        $(BASEDIR2K3)\lib\wnet\amd64,
        
      • Press button [...] right to "Additional Library Directories" and uncheck "Inherit from parent or project defaults" box.
    • "Input"
      • Set list of import libraries for DDK libraires in "Additional Dependencies":
        ntoskrnl.lib
        Hal.lib
        
        Note 1: here the separator character is space character. Do not take paths in quotation marks.
        Note 2: int64.lib doesn't exist for x64 platform.
      • Press button [...] right to "Additional Dependencies" and uncheck "Inherit from parent or project defaults" box.
      • "Ignore all default libraries" = "Yes (/NODEFAULTLIB)"
    • "Debugging"
      • "Generate Debug Info" = "Yes (/DEBUG)"
    • "System"
      • "SubSystem" = "Native (/SUBSYSTEM:NATIVE)"
      • "Driver" = "Driver (/DRIVER)"
    • "Advanced"
      • "Entry point symbol" = "DriverEntry"
    • -> Command Line
      • Separately for each configuration add "/safeseh:no" switch.
  • OK
  • File -> Save All
  • And now copy this empty project somewhere for future use as template for your driver projects :) For example: driver_template_v7.rar/tgz (9.4 Kb/10.1 Kb)

Comments to the sample

Along with main thing - pch_cpp_x64 archive includes previous driver project for Win32 with some updates. Inside pch_cpp_x64 you can find VC8 project with both Win32 and x64 configurations. This project requires you to install x64 support in VC8. There is also Makefile which can be used with nmake from either VC6 or VC8. There is no VC6 project for x64 since I don't know how to set alternative compiler for x64 configurations. Makefile expects DDK 2003 presence for x64 configuration and DDK NT4 for Win32.

FolderPlatformVStudioSourcesPrecompiled headersMakefile
pch_cpp_x64x86/x64VC8.CPPYesYes
vc8_pch_cppx86VC8.CPPYesNo
pch_cppx86VC6/VC8.CPPYesYes
pch_cx86VC6.CYesYes
simplex86VC6.CNoYes
2007.10.30

See also:

<< Back designed by Alter aka Alexander A. Telyatnikov powered by Apache+PHP under FBSD © 2002-2017