Alter.Org.UA  
 << Back Home RU ru   Donate Donate www/www1/www2

MS Visual Studio 6.0 tips

HOWTO to make .DSP and .DSW startable

MS Visual Studio has project files - .DSP and workspace files - .DSW. .DSP contains list of sources and build rules. .DSW file contains list of project files. By default workspace files are opened by MSDev, but project files have no handler. I found it to be inconvenient. You can fix it by importing .REG file with content similar to shown below:


REGEDIT4

[HKEY_CLASSES_ROOT\dspfile\shell\Open]
@="Open"

[HKEY_CLASSES_ROOT\dspfile\shell\Open\command]
@="\"C:\\Program Files\\VC6\\MSDev98\\Bin\\msdev.exe\" \"%1\""

[HKEY_CLASSES_ROOT\dspfile\shell\Open\ddeexec]
@="Open(\"%1\")"

[HKEY_CLASSES_ROOT\dspfile\shell\Open\ddeexec\application]
@="msdev"

[HKEY_CLASSES_ROOT\dspfile\shell\Open\ddeexec\topic]
@="system"

Here is REG-file itself: dsp_start.reg
You can also do it using standard system tools only:
  1. Click with right mouse button (or with left one if you have left-handed mouse) on any .DSP file.
  2. Choose 'Open With...' in context menu
  3. Choose msdev item in list
  4. Check 'Always use this program to open this file' option
  5. Click 'OK'

HOWTO paint Visial Studio IDE to pretty Black background with highliting

Saying truth, I don't understand how ones can look at white backgroung. The monitor lights like a bright lamp. I'm not surprised on troubles with eyes. I propose the following highliting:
Source editor:


#include "ora_common.h"

/* Define one logon data area and one cursor data area
Also define a host data area for olog.
(See ocidfn.h for declarations). */

Lda_Def lda;
Cda_Def cda;
ub4 hda[HDA_SIZE /(sizeof(ub4))];


Debug windows:


EAX = 009E0E80
EBX = 7FFDF000
ECX = 00000001
EDX = 009E0D90
ESI = 00000000
EDI = 00000000


These settings are stored under the following Registry keys:

HKEY_CURRENT_USER\Software\Microsoft\DevStudio\6.0\Format
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\6.0\Text Editor\Colors

Here are the archives with settings: vc6_black_colors.rar/tgz (1.4 Kb/1.5 Kb)

You can also change these settings via Tools -> Customize... -> Keyboard

HOWTO make Visial Studio IDE hot-keys like they was in Borland products

It is just for fun. I like Borland-style keyboard layout (F7 - Step into, F8 - Step over, F5 - Go, etc.). These settings are stored here:

HKEY_CURRENT_USER\Software\Microsoft\DevStudio\6.0\Keyboard

Here are the archives with settings: vc6_borland_kbd.rar/tgz (1 Kb/1.1 Kb)

You can also change these settings via Tools -> Options -> Format

HOWTO view cp-1251 or koi-8 sources in Visial Studio

Install Fixed fonts with appropriate character sets and set up Visual Studio to use these fonts. Use "TermiBCB" or "CourBCB" for cp-1251 and "ER Kurier KOI-8" for koi-8. Of course, it is not very convenient. IMHO, Far (http://www.rarlab.com) internal editor is much better for this case.

Visial Studio IDE features

I've found that many people doesn't know about very useful features. So I decided to list them here. Chose what you like. All options listed below can be found under Tools -> Options menu.

  • Debug, Hexadecimal display. Use hexedecimal form by default.
  • Debug, Display Unicode Strings. Show WCHAR[], PWCHAR, etc. as normal text string during debug.
  • Debug, View floating point registers. Show math co-processor registers in Registers debug window.
  • Compatibility, Enable copy without selection. Using Ctrl-C or Ctrl-Ins when no text is selected will place the whole current line into clip-board.
  • Compatibility, Enable line-mode pastes. If clip-board contains entire line, Ctrl-V or Shift-Ins will place it before current line. Whithout this option the line will be inserted into current cursor position. This option is convenient together with previous one.
  • Compatibility, Enable virtual space. Allows moving cursor beyond end of line. This options prevents changes of horisontal coordinate of cursor when scrolling to shorter lines.
  • Workspace, Recent workspace list contains:. How many workspaces should VC remember and show under File -> Recent Workspaces.
2004.12.24

See also:

<< Back designed by Alter aka Alexander A. Telyatnikov powered by Apache+PHP under FBSD © 2002-2017