Alter.Org.UA  
 << Back Home EN en   Donate Donate www/www1/www2

MS Visual Studio 6.0 tips

HOWTO to make .DSP and .DSW startable

У MS Visual Studio есть проектные файлы - .DSP, содержащие список исходников и правила сборки проекта, а также файлы рабочего места (workspace) - .DSW, содержащие список из 1 или более проектных файлов. По умолчанию .DSW открываются оболочкой MSDev, а .DSP не имеют обработчика по умолчанию. По моему мнению не совсем удобно. Это можно исправить, проимпортировав .REG-файл примерно следующего содержания:


REGEDIT4

[HKEY_CLASSES_ROOT\dspfile\shell\Open]
@="Open"

[HKEY_CLASSES_ROOT\dspfile\shell\Open\command]
@="\"C:\\Program Files\\VC6\\MSDev98\\Bin\\msdev.exe\" \"%1\""

[HKEY_CLASSES_ROOT\dspfile\shell\Open\ddeexec]
@="Open(\"%1\")"

[HKEY_CLASSES_ROOT\dspfile\shell\Open\ddeexec\application]
@="msdev"

[HKEY_CLASSES_ROOT\dspfile\shell\Open\ddeexec\topic]
@="system"

Вот сам REG-файл: dsp_start.reg

Этого же эффекта можно достичь стандартными средствами:

  1. Щелкаем правой (у кого left-handed мыша - левой) кнопкой мыши на любом .DSP файле.
  2. Выбираем пункт 'Open With...' ('Открыть с помощью...')
  3. Выбираем в списке пункт msdev
  4. ставим галку в 'Always use this program to open this file' ('Всегда использовать эту программу....')
  5. Жмем 'OK'

HOWTO paint Visial Studio IDE to pretty Black background with highliting

Честно говоря, я не понимаю, как можно целыми днями смотреть на белый фон. Ведь светится как лампочка. Неудивительно, что начинаются проблемы с глазами. Предлагаю вот такую раскраску:
Source editor:


#include "ora_common.h"

/* Define one logon data area and one cursor data area
Also define a host data area for olog.
(See ocidfn.h for declarations). */

Lda_Def lda;
Cda_Def cda;
ub4 hda[HDA_SIZE /(sizeof(ub4))];


Debug windows:


EAX = 009E0E80
EBX = 7FFDF000
ECX = 00000001
EDX = 009E0D90
ESI = 00000000
EDI = 00000000


Эти настройки хранятся в следующих ключах Registry:

HKEY_CURRENT_USER\Software\Microsoft\DevStudio\6.0\Format
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\6.0\Text Editor\Colors

Вот архивы с настройками: vc6_black_colors.rar/tgz (1.4 Kb/1.5 Kb)

Эти настройки можно изменить через Tools -> Customize... -> Keyboard

HOWTO make Visial Studio IDE hot-keys like they was in Borland products

На любителя. Лично мне более привычна Borland'овкая раскладка (F7 - Step into, F8 - Step over, F5 - Go, etc.). Хранится информация о раскладке вот где:

HKEY_CURRENT_USER\Software\Microsoft\DevStudio\6.0\Keyboard

Вот архивы с настройками: vc6_borland_kbd.rar/tgz (1 Kb/1.1 Kb)

Эти настройки можно изменить через Tools -> Options -> Format

HOWTO view cp-1251 or koi-8 sources in Visial Studio

Добавить в систему Fixed шрифты с соответствующей кодировкой и настроить Visual Studio на использование этих шрифтов. "TermiBCB" или "CourBCB" для cp-1251 и "ER Kurier KOI-8" для koi-8. Конечно, не совсем удобно, придется каждый раз менять шрифт по умолчанию. В этом отношении редактор Far'а (http://www.rarlab.com) очень хорош.

Visial Studio IDE features

Оказалось, что очень многие не знают о ряде супер-полезных фич. Так что привожу список, может кому пригодится. Все это находится в меню Tools -> Options.

  • Debug, Hexadecimal display. По умолчанию использовать 16-ричное представление чисел
  • Debug, Display Unicode Strings. При отладке показывать WCHAR[], PWCHAR и им подобные как текстовые строки.
  • Debug, View floating point registers. Показывать содержимое регистров сопроцессора в окне Registers.
  • Compatibility, Enable copy without selection. Использование Ctrl-C или Ctrl-Ins при отсутствии вылеленного текста приведет к помещению в clip-board всей текущей строки.
  • Compatibility, Enable line-mode pastes. Если в clip-board находится целая строка, Ctrl-V или Shift-Ins вставит ее перед текущей, а не в позицию курсора. Очень удобно в сочетании с предыдущей опцией.
  • Compatibility, Enable virtual space. Позволяет бродить курсором за пределом конца строки. При использовании этой опции курсор не будет скакать по горизонтали при прокрутке в случае попадания на более короткую строку.
  • Workspace, Recent workspace list contains:. Сколько workspace'ов помнить и показывать в File -> Recent Workspaces
2004.12.24

См. также

<< Back Автор: Alter (Александр А. Телятников) Сервер: Apache+PHP под FBSD © 2002-2017